pixfirewall(config-router)# sh run
interface Ethernet0
nameif inside
security-level 100
ip address 172.16.1.1 255.255.255.0
!
interface Ethernet1
nameif outside
security-level 0
ip address 192.168.1.1 255.255.255.0
!
access-list nat extended permit ip 1.0.0.0 255.0.0.0 any
access-list permit extended permit ip any host 192.168.1.1
global (outside) 1 interface
nat (inside) 1 access-list nat
static (inside,outside) tcp interface telnet 1.1.1.1 telnet netmask 255.255.255.255
access-group permit in interface outside
!
router rip ----启动rip路由协议
network 172.16.0.0 ----宣告网络
network 192.168.1.0
version 1 ----版本为1
no auto-summary ----关闭自动汇总
pixfirewall(config-router)#
pixfirewall(config-router)# sh route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
R 1.0.0.0 255.0.0.0 [120/1] via 172.16.1.2, 0:00:17, inside
R 2.0.0.0 255.0.0.0 [120/1] via 192.168.1.2, 0:00:00, outside
C 172.16.1.0 255.255.255.0 is directly connected, inside
C 10.10.1.0 255.255.255.0 is directly connected, dmz
C 192.168.1.0 255.255.255.0 is directly connected, outside
pixfirewall(config-router)#
R1#sh run
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Loopback1
ip address 1.2.1.1 255.255.255.0
!
interface Loopback2
ip address 1.3.1.1 255.255.255.0
!
interface Loopback3
ip address 1.4.1.1 255.255.255.0
!
interface Loopback4
ip address 1.5.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.1.2 255.255.255.0
duplex auto
speed auto
!
router rip
version 1
network 1.0.0.0
network 172.16.0.0
no auto-summary
R1#
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 5 subnets
C 1.1.1.0 is directly connected, Loopback0
C 1.2.1.0 is directly connected, Loopback1
C 1.3.1.0 is directly connected, Loopback2
C 1.4.1.0 is directly connected, Loopback3
C 1.5.1.0 is directly connected, Loopback4
R 2.0.0.0/8 [120/2] via 172.16.1.1, 00:00:05, FastEthernet0/0
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.1.0 is directly connected, FastEthernet0/0
R 192.168.1.0/24 [120/1] via 172.16.1.1, 00:00:05, FastEthernet0/0
R1#
R2#sh run
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 1
network 2.0.0.0
network 192.168.1.0
no auto-summary
R2#
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
R 1.0.0.0/8 [120/2] via 192.168.1.1, 00:00:11, FastEthernet0/0
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0
R 172.16.0.0/16 [120/1] via 192.168.1.1, 00:00:11, FastEthernet0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
R2#