在路上!~~~~

暂无签名

  • 博客访问: 115976
  • 博文数量: 65
  • 博客积分: 0
  • 博客等级: 民兵
  • 技术积分: 440
  • 用 户 组: 普通用户
  • 注册时间: 2015-11-25 09:52
  • 认证徽章:
个人简介

no pains no gains

文章分类

全部博文(65)

文章存档

2017年(8)

2016年(40)

2015年(17)

我的朋友
微信关注

IT168企业级官微



微信号:IT168qiye



系统架构师大会



微信号:SACC2013

订阅
热词专题

分类: 系统运维

1、报错信息如下:
  1. [root@develop bin]# yum  
  2. [root@develop local]# yum -y install prce  
  3. There was a problem importing one of the Python modules  
  4. required to run yum. The error leading to this problem was:  
  5.   
  6.   
  7.    No module named yum  
  8.   
  9.   
  10. Please install a package which provides this module, or  
  11. verify that the module is installed correctly.  
  12.   
  13.   
  14. It's possible that the above module doesn't match the  
  15. current version of Python, which is:  
  16. 2.6.1 (r261:67515, Aug 7 2010, 11:36:17)  
  17. [GCC 4.1.2 20080704 (Red Hat 4.1.2-44)]  
  18.   
  19.   
  20. If you cannot solve this problem yourself, please go to  
  21. the yum faq at:  
  22. http://wiki.linux.duke.edu/YumFaq  




错误原因:错误信息描述为 yum 所依赖的python 不相符,请安装相对应的python即可


2、查看yum版本
[root@develop local]# rpm -qa |grep yum
yum-3.2.8-9.el5.centos.1
yum-metadata-parser-1.1.2-2.el5


3、查看python版本
  1. [root@develop local]# whereis python  
  2. python: /usr/bin/python2.4 /usr/bin/python /usr/lib/python2.4 /usr/local/bin/python2.6 /usr/local/bin/python2.6-config /usr/local/bin/python /usr/local/lib/python2.6 /usr/share/man/man1/python.1.gz  



果然装了两个版本python


4、执行python,查看到使用2.6.1的版本
  1. [root@develop local]# python  
  2. Python 2.6.1 (r261:67515, Aug 7 2010, 11:36:17)  
  3. [GCC 4.1.2 20080704 (Red Hat 4.1.2-44)] on linux2  
  4. Type "help", "copyright", "credits" or "license" for more information.  
  5. >>>  




5、猜测yum调用了高版本的python。


6、解决方法:
查找yum和 yum-updatest文件,并编辑此py文件
  1. [root@develop local]# which yum  
  2. /usr/bin/yum  
  3. [root@develop local]# vi /usr/bin/yum  
  1. [root@develop local]# vi /usr/bin/yum-updatest  




#!/usr/bin/python
改为:
#!/usr/bin/python2.4


然后保存OK.

如果不修改/usr/bin/yum ,则yum无法使用

如果不修改/usr/bin/yum-updatest  会出现如下错误

 File "/usr/sbin/yum-updatesd", line 35, in <module>
    import dbus
ImportError: No module named dbus



当然,修改完后记着

  1. [root@localhost google_appengine]# /sbin/service yum-updatesd restart  
  2. Stopping yum-updatesd:                                     [FAILED]  
  3. Starting yum-updatesd:                                     [  OK  ]  


补充:yum基于python写的。
阅读(131) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~
评论热议
请登录后评论。

登录 注册