Chinaunix首页 | 论坛 | 博客
  • 博客访问: 2634756
  • 博文数量: 258
  • 博客积分: 9440
  • 博客等级: 少将
  • 技术积分: 6998
  • 用 户 组: 普通用户
  • 注册时间: 2009-05-03 10:28
个人简介

-- linux爱好者,业余时间热衷于分析linux内核源码 -- 目前主要研究云计算和虚拟化相关的技术,主要包括libvirt/qemu,openstack,opennebula架构和源码分析。 -- 第五届云计算大会演讲嘉宾 微博:@Marshal-Liu

文章分类

全部博文(258)

文章存档

2016年(1)

2015年(4)

2014年(16)

2013年(22)

2012年(41)

2011年(59)

2010年(40)

2009年(75)

分类: C/C++

2011-10-16 16:18:28

    编译grub-0.97时,执行configure后,出现如下错误:

         configure: error: GRUB requires a working absolute objcopy; upgrade your binutils

    错误提示upgrade your binutils,但是系统安装是最新版本的binutils。其实,这个原因主要是由于gcc的版本引起的,解决方法如下:

    方法一: 采用旧版本的gcc,如gcc-3.4

    方法二:修改configure文件,将objcopy -O binary修改为objcopy -R .note.gnu.build-id -O binary
阅读(2343) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~