Chinaunix首页 | 论坛 | 博客
  • 博客访问: 1344866
  • 博文数量: 167
  • 博客积分: 2108
  • 博客等级: 上尉
  • 技术积分: 3287
  • 用 户 组: 普通用户
  • 注册时间: 2009-02-03 10:37
个人简介

10多年思科技术培训师。独特的以技术为载体,引导和建立思维、学习方法的授课技巧;丰富的大型企业定制培训经验;数年网络方案设计;专注技术架构;开思科技术书籍本地化先河;荣获2010和2012年读者最喜爱的作者奖;携手白宫通信局服务2011年美副总统拜登访华;全国高等职业技能大赛命题专家;

文章分类
文章存档

2017年(1)

2016年(2)

2015年(5)

2014年(15)

2013年(9)

2012年(24)

2011年(43)

2010年(35)

2009年(33)

分类: 系统运维

2009-02-05 10:24:05

4.5        配置OSPFv3

提示:本小节使用的命令基于IOS 12.4T

4.5.1  基本配置命令

1. 启动IPv6单播路由功能

命令语法如下:

router(config)# ipv6 unicast-routing

2. 在接口上启用IPv6

命令语法如下:

router(config-if)# ipv6 enable

该命令可以使一个没有配置IPv6地址的接口启用IPv6进程,并自动为接口配置一个本链路(link-local)地址。

1)下面的输出显示了f0/0接口上没有启用IPv6和启用IPv6后的不同情况。

FastEthernet0/0 is up, line protocol is up

  Hardware is AmdFE, address is 000e.38ee.39a0 (bia 000e.38ee.39a0)

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

(略)

输出显示,f0/0接口的MAC地址是000e.38ee.39a0

启用IPv6后的输出如下:

FastEthernet0/0 is up, line protocol is up

  IPv6 is enabled, link-local address is FE80::20E:38FF:FEEE:39A0

  No global unicast address is configured

  Joined group address(es):

    FF02::1

    FF02::1:FFEE:39A0

  MTU is 1500 bytes

  ICMP error messages limited to one every 100 milliseconds

  ICMP redirects are enabled

  ND DAD is enabled, number of DAD attempts: 1

  ND reachable time is 30000 milliseconds

输出显示,启用IPv6的以太接口自动把MAC地址转换成EUI-64格式,构成本链路地址。该接口也自动加入两个组播组中:本链路范围内所有IPv6节点组和被请求节点组中。

2)下面的输出显示的是在s0/0接口上启用IPv6后的情况。

Serial0/0 is up, line protocol is up

  IPv6 is enabled, link-local address is FE80::20E:38FF:FEEE:39A0

  No global unicast address is configured

  Joined group address(es):

    FF02::1

    FF02::1:FFEE:39A0

  MTU is 1500 bytes

  ICMP error messages limited to one every 100 milliseconds

  ICMP redirects are enabled

  ND DAD is enabled, number of DAD attempts: 1

  ND reachable time is 30000 milliseconds

输出显示,点到点链路上的接口使用了以太接口的MAC地址转换为EUI-64地址,构成其本链路地址。

3. 为接口设置单点传送地址

为运行IPv6的路由器接口设置地址的方法有多种,下面介绍3种常用的方法。

1)直接手工设置地址。

命令语法如下:

router(config-if)# ipv6 address ipv6-address/prefix-length

ipv6-address/prefix-lengthIPv6地址及地址前缀长度。

2)自动使用基于EUI-64格式的主机地址。

命令语法如下:

router(config-if)# ipv6 address ipv6-prefix/prefix-length eui-64

ipv6-prefix/prefix-lengthIPv6地址前缀及前缀长度。

该命令相当于为接口设置了网络前缀,节点号就直接使用了符合EUI-64格式的接口地址(接口物理地址)。如果设置的前缀长度大于64,前缀中的比特位优先于接口地址的比特位。

在接口上设置IPv6地址,就自动启用了该接口的IPv6进程,并且”no ipv6 enable”命令不能禁止该接口上的IPv6进程。

例如,为接口ethernet 0设置IPv6地址:

Router(config)# interface fastethernet 0/0

Router(config-if)# ipv6 address 2006 : 1010 : 0 : 1 :: /64  eui-64

设置了全球单点传送地址后的输出如下:

FastEthernet0/0 is up, line protocol is up

  IPv6 is enabled, link-local address is FE80::20E:38FF:FEEE:39A0

  Global unicast address(es):

    2006:1010:0:1:20E:38FF:FEEE:39A0, subnet is 2006:1010:0:1::/64

  Joined group address(es):

    FF02::1

    FF02::1:FFEE:39A0

  MTU is 1500 bytes

  ICMP error messages limited to one every 100 milliseconds

  ICMP redirects are enabled

  ND DAD is enabled, number of DAD attempts: 1

  ND reachable time is 30000 milliseconds

3)自动配置地址。

命令语法如下:

Router(config-if)# ipv6 address autoconfig

该命令启动了IPv6的自动地址配置功能,自动发现链路上的地址前缀,然后在前缀后面自动加上EUI-64格式的接口物理地址,构成接口的IPv6地址。

4. 设置路由器ID

IPv6环境下,可以使用如下几种方式为路由器设置ID号:

1)如果物理接口上设置了IPv4地址,路由器自动选择活跃接口上的最高IPv4地址作为其ID号。

2)如果设置了loopback接口,则优先使用loopback接口地址作为路由器ID。如果存在多个loopback接口,则使用最高接口地址。

3)如果没有任何接口配置了IPv4地址,则必须使用如下命令为路由器设置ID号:

router(config)# ipv6 router ospf process-id

router(config-rtr)# router-id  ipv4-format-id

process-id:进程号;

ipv4-format-idIPv4格式的路由器ID号。

5. 在接口上启用OSPF

命令语法如下:

Router(config-if)# ipv6 ospf process-id area area-id [instance instance-id]

Process-id:进程号;

Area-id:区域号;

Instance-id:实例号。

该命令把接口置于某个OSPF进程的某个区域中,并且还可以声明其使用的实例编号。

在接口上启用OSPF,可以自动启用OSPF进程,不需要再单独使用令ipv6 router ospf process-id 启用进程;该命令也同时启用了IPv6的单播路由功能。

6. 配置路由总结

命令语法如下:

Router(config)# ipv6 router ospf process-id

Router(config-rtr)# area area-id range ipv6-prefix/prefix-length [advertise | not-advertise] [cost cost]

该命令的含义和OSPFv2中的路由总结命令含义相同,其中:

area-id:表示总结某个区域内的路由;

ipv6-prefix/prefix-length:总结后的路由前缀及前缀长度;

advertise:通告该总结路由条目;

not-advertise:不通告该总结路由条目;

cost:为该总结路由赋予的开销值。缺省地,总结路由条目的开销使用被总结路由中的最高开销值。

7. OSPFv3配置示例

提示:下面的实验环境使用的IOS版本是12.3(20) 高级企业特性集。

 图 4-4

配置示例中使用的拓扑如图4-4所示。路由器R1R2通过点到点链路把两个局域网连接起来。两个串行接口运行在区域0中。R1的以太接口和环回接口运行在区域3中,R2的以太接口和环回接口运行在区域2中。下面分别配置R1R2

1)配置路由器R1

Router1#config t

Router1(config)#ipv6 unicast-routing

router1(config)#ipv6 router ospf 1

router1(config-rtr)#router-id 1.1.1.1

router1(config-rtr)#exit

router1(config)#interface f0/0

router1(config-if)#ipv6 address 2006:1010:0:1::/64 eui-64

router1(config-if)# ipv6 ospf 1 area 3

router1(config-if)#interface s0/0

router1(config-if)# ipv6 ospf 1 area 0

router1(config-if)#exit

router1(config)#interface loopback 1

router1(config-if)#ipv6 address 2006:1010:0:2::/64 eui-64

router1(config-if)#ipv6 ospf 1 area 3

router1(config-if)#interface loopback 2

router1(config-if)#ipv6 add 2006:1010:0:3::/64 eui-64

router1(config-if)#ipv6 ospf 1 area 3

router1(config-if)#exit

router1(config)#

配置完成后的配置列表如下所示(仅列出相关内容):

hostname router1

!

ipv6 unicast-routing

!

interface Loopback1

 no ip address

 ipv6 address 2006:1010:0:2::/64 eui-64

 ipv6 ospf 1 area 3

!

interface Loopback2

 no ip address

 ipv6 address 2006:1010:0:3::/64 eui-64

 ipv6 ospf 1 area 3

!

interface FastEthernet0/0

 no ip address

 duplex auto

 speed auto

 ipv6 address 2006:1010:0:1::/64 eui-64

 ipv6 enable

 ipv6 ospf 1 area 3

!

interface Serial0/0

 no ip address

 ipv6 enable

 ipv6 ospf 1 area 0

 no fair-queue

!

ipv6 router ospf 1

 router-id 1.1.1.1

 log-adjacency-changes

2)配置路由器R2

Router2#config t

Router2(config)#ipv6 unicast-routing

Router2(config)#ipv6 router ospf 1

Router2(config-rtr)#router-id 2.2.2.2

Router2(config-rtr)#exit

Router2(config)#interface f0/0

Router2(config-if)#ipv6 address 2006:1010:0:5::/64 eui-64

Router2(config-if)# ipv6 ospf 1 area 2

Router2(config-if)#interface s0/0

Router2(config-if)# ipv6 ospf 1 area 0

Router2(config-if)#exit

Router2(config)#interface loopback 1

Router2(config-if)#ipv6 address 2006:1010:0:6::/64 eui-64

Router2(config-if)#ipv6 ospf 1 area 2

Router2(config-if)#interface loopback 2

Router2(config-if)#ipv6 add 2006:1010:0:7::/64 eui-64

Router2(config-if)#ipv6 ospf 1 area 2

Router2(config-if)#exit

Router2(config)#

配置完成后的配置列表如下所示(仅列出相关内容):

hostname router2

!

ipv6 unicast-routing

!

interface Loopback1

 no ip address

 ipv6 address 2006:1010:0:6::/64 eui-64

 ipv6 ospf 1 area 2

!

interface Loopback2

 no ip address

 ipv6 address 2006:1010:0:7::/64 eui-64

 ipv6 ospf 1 area 2

!

interface FastEthernet0/0

 no ip address

 duplex auto

 speed auto

 ipv6 address 2006:1010:0:5::/64 eui-64

 ipv6 ospf 1 area 2

!

interface Serial0/0

 no ip address

 ipv6 enable

 ipv6 ospf 1 area 0

!

ipv6 router ospf 1

 router-id 2.2.2.2



阅读(3176) | 评论(0) | 转发(1) |
给主人留下些什么吧!~~