拓扑图
R1#
R1#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
enable password cisco
!
ip subnet-zero
clns routing
!
!
interface Ethernet0
no ip address
no ip directed-broadcast
shutdown
!
interface Ethernet1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0
ip address 192.168.1.2 255.255.255.0
no ip directed-broadcast
ip router isis
no ip mroute-cache
clockrate 1300000
clns router isis
isis circuit-type level-1
!
interface Serial1
ip address 10.10.10.1 255.255.255.0
no ip directed-broadcast
ip router isis
clockrate 1300000
clns router isis
isis circuit-type level-2-only
!
router isis
net 49.0001.1111.1111.1111.00
!
ip classless
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end
R1#
R1#
R1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR
Gateway of last resort is not set
172.168.0.0/24 is subnetted, 1 subnets
i L1 172.168.1.0 [115/20] via 192.168.1.1, Serial0
172.31.0.0/24 is subnetted, 1 subnets
i L2 172.31.1.0 [115/50] via 10.10.10.2, Serial1
10.0.0.0/24 is subnetted, 2 subnets
C 10.10.10.0 is directly connected, Serial1
i L2 10.10.20.0 [115/30] via 10.10.10.2, Serial1
C 192.168.1.0/24 is directly connected, Serial0
i L2 192.168.2.0/24 [115/20] via 10.10.10.2, Serial1
i L2 192.168.3.0/24 [115/40] via 10.10.10.2, Serial1
R1#
R1#sh isis route
IS-IS Level-1 Routing Table - version 15
System Id Next-Hop Interface SNPA Metric State
1111.1111.1111 --
2222.2222.2222 2222.2222.2222 Se0 *HDLC* 10 Up
R1#
R1#sh clns route
CLNS Prefix Routing Table
49.0001.1111.1111.1111.00, Local NET Entry
49.0003 [110/30]
via 3333.3333.3333, IS-IS, Up, Serial1
49.0002 [110/10]
via 3333.3333.3333, IS-IS, Up, Serial1
49.0001 [110/0]
via 1111.1111.1111, IS-IS, Up
R1#
R1#sh isis topology
IS-IS paths to level-1 routers
System Id Metric Next-Hop Interface SNPA
1111.1111.1111 --
2222.2222.2222 10 2222.2222.2222 Se0 *HDLC*
IS-IS paths to level-2 routers
System Id Metric Next-Hop Interface SNPA
1111.1111.1111 --
3333.3333.3333 10 3333.3333.3333 Se1 *HDLC*
4444.4444.4444 30 3333.3333.3333 Se1 *HDLC*
6666.6666.6666 20 3333.3333.3333 Se1 *HDLC*
R1#
R1#
R1#ping 172.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms
R1#
=======================================================================
R2#
R2#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
enable password cisco
!
ip subnet-zero
clns routing
!
!
interface Loopback0
ip address 172.168.1.1 255.255.255.0
no ip directed-broadcast
ip router isis
!
interface Ethernet0
no ip address
no ip directed-broadcast
shutdown
!
interface Ethernet1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
ip router isis
clns router isis
isis circuit-type level-1
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
router isis
net 49.0001.2222.2222.2222.00
!
ip classless
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end
R2#
R2#
R2#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR
Gateway of last resort is 192.168.1.2 to network 0.0.0.0
172.168.0.0/24 is subnetted, 1 subnets
C 172.168.1.0 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Serial0
i*L1 0.0.0.0/0 [115/10] via 192.168.1.2, Serial0
R2#
R2#sh isis route
IS-IS Level-1 Routing Table - version 11
System Id Next-Hop Interface SNPA Metric State
1111.1111.1111 1111.1111.1111 Se0 *HDLC* 10 Up L2-IS
2222.2222.2222 --
Default route out of area - (via 1 L2-attached IS)
System Id Next-Hop Interface SNPA Metric State
1111.1111.1111 Se0 *HDLC* 10 Up
R2#
R2#sh clns route
CLNS Prefix Routing Table
49.0001.2222.2222.2222.00, Local NET Entry
49.0001 [110/0]
via 2222.2222.2222, IS-IS, Up
R2#
R2#sh isis topology
IS-IS paths to level-1 routers
System Id Metric Next-Hop Interface SNPA
1111.1111.1111 10 1111.1111.1111 Se0 *HDLC*
2222.2222.2222 --
IS-IS paths to level-2 routers
System Id Metric Next-Hop Interface SNPA
2222.2222.2222 --
R2#
R2#
R2#ping 172.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
R2#
===================================================================
R3#
R3#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
enable secret 5 $1$e2d8$zR7.2yGNSceuaIpQjlqjQ/
!
ip subnet-zero
clns routing
!
!
interface Ethernet0
ip address 192.168.2.1 255.255.255.0
no ip directed-broadcast
ip router isis
clns router isis
isis circuit-type level-2-only
!
interface Serial0
ip address 10.10.10.2 255.255.255.0
no ip directed-broadcast
ip
【责编:admin】
--------------------next---------------------