Chinaunix首页 | 论坛 | 博客
  • 博客访问: 646148
  • 博文数量: 751
  • 博客积分: 5000
  • 博客等级: 大校
  • 技术积分: 4990
  • 用 户 组: 普通用户
  • 注册时间: 2008-10-28 09:48
文章分类

全部博文(751)

文章存档

2011年(1)

2008年(750)

我的朋友

分类:

2008-10-28 09:51:57


   
  The NSAP address
  A network entity title (NET) is an NSAP with an n-selector of zero.
  AFI 为 1 byte 通常 lab 都用 49 (保留用)
  System ID 为 6 bytes ( 就是 MAC Address 但也可以自订)
  NSEL 在这为 00 1 byte
  Area Address 为可变长度字段 1byte ~ 13 bytes
  例: 49.0001.1111.1111.1111.00
  1111.1111.1111 为 MAC Address 值 49.0001 为 Area Address
  
  !
  interface Ethernet0
  ip address 172.16.12.1 255.255.255.0
  ip router isis
  
  !--- Assigns IP address to interface Ethernet0
  !--- and enables IS-IS for IP on the interface.
  !
  router isis
  net 49.0001.1111.1111.1111.00
  !
  !--- Enables the IS-IS process on the router,
  !--- and assigns area and system ID to router.
  
  要激活 ISIS 的 IP routing 只要 3 个指令
  Router(config)#router isis
  Router(config-router)#net 49.0001.1111.1111.1111.00
  在要激活 IS-IS routing 的 interface 上
  Router(config-if)#ip router isis
  
  如此就激活了 ISIS
  
   用这次做 Lab 的 topology 来做解说
  R1 是 Area 49.0001 上的 ABR
  与 R2 用 Level 1 的 routing
  与 R3 用 Level 2 的 routing
  
  !
  hostname R1
  !
  enable password cisco
  !
  ip subnet-zero
  clns routing
  !----有激活 clns 的 routing
  !
  !
  interface Ethernet0
  no ip address
  no ip directed-broadcast
  shutdown
  !
  interface Ethernet1
  no ip address
  no ip directed-broadcast
  shutdown
  !
  interface Serial0
  ip address 192.168.1.2 255.255.255.0
  no ip directed-broadcast
  ip router isis
  !----激活 ip routing
  no ip mroute-cache
  clockrate 1300000
  clns router isis
  !----激活 clns routing
  isis circuit-type level-1
  !----宣告 serial 0 用 level-1 routing
  !
  interface Serial1
  ip address 10.10.10.1 255.255.255.0
  no ip directed-broadcast
  ip router isis
  clockrate 1300000
  clns router isis
  isis circuit-type level-2-only
  !----宣告 serial 1 用 level-2 routing
  !
  router isis
  net 49.0001.1111.1111.1111.00
  !----激活 isis routing process 与 输入 nsap address
  !
  ip classless
  !
  !
  !
  line con 0
  transport input none
  line aux 0
  line vty 0 4
  password cisco
  login
  !
  end
  
  R1#
  R1#
  R1#sh ip route
  Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
  D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
  N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
  E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
  i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
  U - per-user static route, o - ODR
  
  Gateway of last resort is not set
  
  172.168.0.0/24 is subnetted, 1 subnets
  i L1 172.168.1.0 [115/20] via 192.168.1.1, Serial0
  172.31.0.0/24 is subnetted, 1 subnets
  i L2 172.31.1.0 [115/50] via 10.10.10.2, Serial1
  10.0.0.0/24 is subnetted, 2 subnets
  C 10.10.10.0 is directly connected, Serial1
  i L2 10.10.20.0 [115/30] via 10.10.10.2, Serial1
  C 192.168.1.0/24 is directly connected, Serial0
  i L2 192.168.2.0/24 [115/20] via 10.10.10.2, Serial1
  i L2 192.168.3.0/24 [115/40] via 10.10.10.2, Serial1
  R1#
  
  L1 代表由 Level-1 routing 学来的
  L2 由 Level-2 routing 学来
  ps. router 预设会把 Level-1 与 Level-2 同时激活
  
  
  Show Level-1 Routing Table
  R1#sh isis route
  IS-IS Level-1 Routing Table - version 15
  System Id Next-Hop Interface SNPA Metric State
  1111.1111.1111 --
  2222.2222.2222 2222.2222.2222 Se0 *HDLC* 10 Up
  R1#
  
  
  Show Level-2 Routing Table
  R1#sh clns route
  CLNS Prefix Routing Table
  49.0001.1111.1111.1111.00, Local NET Entry
  49.0003 [110/30]
  via 3333.3333.3333, IS-IS, Up, Serial1
  49.0002 [110/10]
  via 3333.3333.3333, IS-IS, Up, Serial1
  49.0001 [110/0]
  via 1111.1111.1111, IS-IS, Up
  R1#
  
  R1#sh isis topology
  IS-IS paths to level-1 routers
  System Id Metric Next-Hop Interface SNPA
  1111.1111.1111 --
  2222.2222.2222 10 2222.2222.2222 Se0 *HDLC*
  
  IS-IS paths to level-2 routers
  System Id Metric Next-Hop Interface SNPA
  1111.1111.1111 --
  3333.3333.3333 10 3333.3333.3333 Se1 *HDLC*
  4444.4444.4444 30 3333.3333.3333 Se1 *HDLC*
  6666.6666.6666 20 3333.3333.3333 Se1 *HDLC*
  R1#
  R1#
  R1#ping 172.168.1.1
  
  Type escape sequence to abort.
  Sending 5, 100-byte ICMP Echos to 172.168.1.1, timeout is 2 seconds:
  !!!!!
  Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms
  
  
【责编:admin】

--------------------next---------------------

阅读(473) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~