Chinaunix首页 | 论坛 | 博客
  • 博客访问: 1285988
  • 博文数量: 196
  • 博客积分: 4141
  • 博客等级: 中将
  • 技术积分: 2253
  • 用 户 组: 普通用户
  • 注册时间: 2009-03-21 20:04
文章存档

2019年(31)

2016年(1)

2014年(16)

2011年(8)

2010年(25)

2009年(115)

分类:

2009-06-14 20:55:06

QS Network

Time Limit:1sMemory limit:32M
Accepted Submit:158Total Submit:478

In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.

A sample is shown below:


A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.


Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.


Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.


Sample Input

1
3
10 20 30
0 100 200
100 0 300
200 300 0


Sample Output

370

#include <stdio.h>
#include <math.h>
#include <string.h>

int connect[1001][1001];
int price[1001];
int result[1001];
int visit[1001];

int main()
{
    int i, num, sum;
    int j, k, cable;
    int min_val, pos;

    scanf("%d", &num);
    for (i = 1; i <= num; ++i)
    {
        scanf("%d", &cable);
        for (j = 0; j < cable; ++j)
        {
            scanf("%d", &price[j]);
            visit[j] = 0;
        }

        for (j = 0; j < cable; ++j)
        {
            for (k = 0; k < cable; ++k)
            {
                scanf("%d", &connect[j][k]);
                if (j != k)
                    connect[j][k] = connect[j][k] + price[j] + price[k];
            }
        }

        visit[0] = 1;
        for (j = 0; j < cable; ++j)
            result[j] = connect[0][j];

        for (j = 1; j < cable; ++j)
        {
min_val = 100000000;
            for (k = 0; k < cable; ++k)
            {
                if ((visit[k] == 0) && result[k] < min_val)
                {
                    min_val = result[k];
                    pos = k;
                }
            }
            visit[pos] = 1;
            for (k = 0; k < cable; ++k)
            {
                if ((result[k] > connect[pos][k]) && (visit[k] == 0))
                    result[k] = connect[pos][k];
            }
        }
        sum = 0;
        for (j = 0; j < cable; ++j)
            sum += result[j];
        printf("%d\n", sum);
    }

    return 0;
}

阅读(1831) | 评论(0) | 转发(0) |
0

上一篇:Fire Net(二分图)

下一篇:Recaman's Sequence

给主人留下些什么吧!~~