Chinaunix首页 | 论坛 | 博客
  • 博客访问: 6796694
  • 博文数量: 578
  • 博客积分: 13065
  • 博客等级: 上将
  • 技术积分: 10103
  • 用 户 组: 普通用户
  • 注册时间: 2008-03-26 16:44
个人简介

推荐: blog.csdn.net/aquester https://github.com/eyjian https://www.cnblogs.com/aquester http://blog.chinaunix.net/uid/20682147.html

文章分类

全部博文(578)

分类: LINUX

2015-04-14 18:04:24

下面这个错误可能是因为DOS(Windows)和Unix文件格式问题:
checking whether g++ supports C++11 features by default... no
checking whether g++ supports C++11 features with -std=c++11... no
configure: No compiler with C++11 support was found
./configure: line 16746: syntax error near unexpected token `fi'
./configure: line 16746: `fi'
解决方法是设置好git:
[core]
autocrlf = false
safecrlf = true
eol = lf
对应的命令为:
git config --global core.autocrlf false
git config --global core.safecrlf true
git config --global core.eol lf


完成后,删除再重新从git上clone出来。




下面这个错误原因暂不清楚(configure时指定了--with-qt4=no,按理代码应当不会进入才对):
checking for ranlib... (cached) ranlib
checking whether g++ supports C++11 features by default... no
checking whether g++ supports C++11 features with -std=c++11... no
configure: No compiler with C++11 support was found
./configure: line 17658: syntax error near unexpected token `QT,'
./configure: line 17658: `    PKG_CHECK_MODULES(QT, QtCore >= 4.3, QtNetwork >= 4.3, have_qt=yes, have_qt=no)'


但可以编辑configure文件,然后将相应的行注释掉,如:
#  if test "$with_qt4" = "yes";  then
#    PKG_CHECK_MODULES(QT, QtCore >= 4.3, QtNetwork >= 4.3, have_qt=yes, have_qt=no)
#  fi


其它类似的错误都可以这样处理。


下面这个错误发生在x86_64上,也根据提示来操作:
/usr/local/thirdparty/openssl/include/openssl/sha.h:184: error: ISO C++ does not support 'long long'
/usr/local/thirdparty/openssl/include/openssl/sha.h:185: error: ISO C++ does not support 'long long'
/usr/local/thirdparty/openssl/include/openssl/sha.h:187: error: ISO C++ does not support 'long long'


修改sha.h的相应代码行,将SHA_LONG64改成int64_t(需要#include )或long即可。
阅读(9524) | 评论(6) | 转发(0) |
给主人留下些什么吧!~~

Aquester2018-08-02 16:20:10

Aquester:thrift-0.9.3编译和0.9.0稍不同,标准方式指定openssl:
./configure --prefix=/usr/local/thrift-0.9.3 CPPFLAGS=\"-fPIC\" LDFLAGS=\"-fPIC\" --with-libevent=/usr/local/libevent --with-boost=/usr/local/boost --with-openssl=/usr/local/openssl --enable-tutorial=no --enable-tests=no --enable-coverage=no --with-cpp=yes --with-java=yes --with-php=yes --with-ruby=no --with-python=no --with-erlang=no --with-csharp=no --with-qt4=no --with-qt5=no --with-c_glib=no --with-perl=no --with-haskell=no

如果不以标准方式,则报错:
configure: error: \"Error: libcrypto required.\"

回复 | 举报

Aquester2017-08-17 16:01:44

thrift-0.9.3编译和0.9.0稍不同,标准方式指定openssl:
./configure --prefix=/usr/local/thrift-0.9.3 CPPFLAGS=\"-fPIC\" LDFLAGS=\"-fPIC\" --with-libevent=/usr/local/libevent --with-boost=/usr/local/boost --with-openssl=/usr/local/openssl --enable-tutorial=no --enable-tests=no --enable-coverage=no --with-cpp=yes --with-java=yes --with-php=yes --with-ruby=no --with-python=no --with-erlang=no --with-csharp=no --with-qt4=no --with-qt5=no --with-c_glib=no --with-perl=no --with-haskell=no

Aquester2017-08-17 13:29:40

./configure --prefix=/usr/local/thirdparty/thrift-0.9.3 --with-libevent=/usr/local/thirdparty/libevent --with-boost=/usr/local/thirdparty/boost CXXFLAGS=\"-I/usr/local/thirdparty/openssl/include\" LDFLAGS=\"-L/usr/local/thirdparty/openssl/lib\" --enable-tutorial=no --enable-tests=no --enable-coverage=no --with-cpp=yes --with-java=yes --with-php=yes --with-ruby=no --with-python=no --with-erlang=no --with-csharp=no --with-qt4=no --with-qt5=no --with-c_glib=no --with-perl=no --w

Aquester2017-08-17 11:42:28

./configure --prefix=/usr/local/thrift-0.9.0 --with-libevent=/usr/local/libevent --with-boost=/usr/local/boost CXXFLAGS=\"-I/usr/local/openssl/include\" LDFLAGS=\"-L/usr/local/openssl/lib\" --with-ruby=no --with-python=no --with-erlang=no --with-csharp=no --with-qt4=no --with-c_glib=no --with-perl=no --with-haskell=no --with-d=no --with-go=no

Aquester2017-02-08 14:32:07

Aquester:64位机器上编译,遇到如下链接错误,依赖的thrift为thrift-0.9.0:
/bin/ld: /usr/local/thrift/lib/libthrift.a(Thrift.o): relocation R_X86_64_32S against `_ZNSs4_Rep20_S_empty_rep_storageE\' can not be used when making a shared object; recompile with -fPIC
/usr/local/thrift/lib/libthrift.a: could not read symbols: 错误的值

解决办法:设置CXXFLAGS,加上-fPIC,重编译thrift,但注意不能是CPPFLAGS,如下所示
 ./configure --prefix=/usr/local/thrift-0.9.0 --with-boost=/usr/local/boost --with-libevent=/us

如下所示的链接错误,可采取同样的方法重编译protobuf,依赖的protobuf为protobuf-2.6.1
/bin/ld: /usr/local/protobuf/lib/libprotobuf.a(common.o): relocation R_X86_64_32S against `_ZTVN6google8protobuf7ClosureE\' can not be used when making a shared object; recompile with -fPIC
/usr/local/protobuf/lib/libprotobuf.a: could not read symbols: 错误的值

重编译protobuf:
./configure --prefix=/usr/local/protobuf-2.6.1 --with-zlib CXXFLAGS=\"-fPIC\"
注意configure后要做下make cle

回复 | 举报
评论热议
请登录后评论。

登录 注册