AIX 部分
xargs
ls |grep del|xargs -I {} mv {} /folder/200707/
ls -l|grep string|xargs rm -fr {}
或者
find . -name “*.log” -exec rm {} \;
vi替换
:%s/old/new/g
删除含特定字符串的行
:g/string/d
删除 string所在的行
mount cdrom
mkdir /mnt/cdrom
mount -rv cdrfs /dev/cd0 /mnt/cdrom
使用nfs
1, 在192.168.1.1的/etc/hosts里面添加需要使用nfs的客户端IP地址与主机名
2, 在客户端先新建一个文件夹作为mount点,命令mount 192.168.1.1:/folder/folderA /nfs_tmp
将文件或文件夹打包:
# tar cvf destination.tar source > /dev/null
# gzip destination.tar > /dev/null
将*.tar.gz文件解开:
# gzip -d destination.tar.gz > /dev/null
# tar xvf desination.tar > /dev/null -----------------慎用,只能用在相对路径的解包
compress -d ese.dbcs.tar.Z
tar xvf ese.dbcs.tar
pax -rvf /worktmp/ivo.tar 将/worktmp/ivo.tar 这个文件解压到当前目录
学会用find
find / -name hosts 查找系统中hosts文件所在位置
find / -name "*.exe" 查找系统中所有.exe的文件
find / -perm 0777 -print|more 查找系统内所有访问权限设置为777的文件
find / -ctime 1 -print|more 查找系统内在当前 24 小时的时间内更改过的所有文件
find . -name '*find*' -print 要找到那些路径名称包含 find 的所有可访问的文件,请输入
find . -size 414c -print 要搜索那些恰好是 414 个字节长的所有文件,请输入:
find /u/arnold -name "*.c" -exec rm {} \; 要找到并删除在您的主目录中后缀为 .c 的每个文件,请输入:
cut
echo "/TFT/1IL/CHAR;3P78000121_1405"|cut -d \; -f1
bootlist相关
设置
bootlist -m normal hdisk0 hdisk1 blv=hd5
查看
bootlist -m normal -o
rootvg做完整的mirror
BLV不是个文件系统,对于这个hd5这个lv, 除了做完mirror之外还需要做一个bosboot -a的动作才可以
no -a 参数修改
no -p -o tcp_keepidle=600
no -p -o tcp_keepintvl=20
no -a|grep tcp_keep
tcp_keepcnt = 8
tcp_keepidle = 600
tcp_keepinit = 150
tcp_keepintvl = 20
这样telnet的session就不会断开了
好习惯 2 的示例:使用选项 -C 来解压缩 .tar 存档文件
~ $ tar xvf -C tmp/a/b/c newarc.tar.gz
再注意tar的相对路径,绝对路径的问题
# lsdev -Cc memory
L2cache0 Available L2 Cache
mem0 Available Memory
# lsattr -El mem0
goodsize 5760 Amount of usable physical memory in Mbytes False
size 5760 Total amount of physical memory in Mbytes False
lsdev
则可以用来查询cpu的信息
如
# lsdev -Cc processor
proc0 Available 00-00 Processor
proc2 Available 00-02 Processor
proc4 Available 00-04 Processor
这里表示有三颗可用的cpu。
lsattr则可以分别列出这些CPU的主频等信息
# lsattr -El proc0
frequency 1656400000 Processor Speed False
state enable Processor state False
type PowerPC_POWER5 Processor type False
其实,通过vmstat等命令,也完全可以查看cpu与内存的信息,如
lscfg -vl
=================================================================================
3 应用程序内存泄露对Paging Space使用率的影响
应用程序的内存泄露也是造成Paging Space使用率不断增长的另一常见原因,此类情况的解决方法主要是找出内存泄露的应用,然后进行修正或安装补丁。
以下方法可用来找出发生内存泄露的应用:
该命令每m秒钟按降序列出前n个最耗内存进程。为了便于分析,可以将结果输出到文件中,然后对内容进行分析,从而找出内存泄露的应用。
下例中命令svmon -P -t 10 -i 5的结果被输出到文件svmonresult.txt中,该命令每5秒种输出一次最耗内存的前10个进程。
==========================================================================================
查看特定用户拥有的进程
ps -f -l -u kabusr1
==============================================================================
将文本按行倒序
tac urfile
sed '1!G;h;$!d' urfile
awk计算行值
awk '{print $1+$2}' urfile
awk计算列值
awk 'BEGIN{total=0}{total+=$1}END{print total}' urfile
perl计算行值
perl -ane '{$total=@F[0]+@F[1];print $total;print "\n"}' urfile
perl计算列值
perl -ane '{$total+=@F[0];}END{print $total;print "\n"}' urfile
删除包含aaa但不包含bbb的行
sed '/aaa/{/bbb/!d}' urfile
最好是使用
smit route
去更改,设置静态路由,所有的网卡只能有同样的静态路由
数据包找路由的步骤大致是这样的,先找本网段的,再找路由表中有记录的网络(找到下一跳),所有的网络都找不到再找default路由
alt_disk_install 是aix中一个非常好用的工具,其中一个最经常用到的功能就是复制系统。尤其在多台服务器/分区环境要求一致,但是需要快速部署的情况下。
下面的例子就是把已经在服务器上在hdisk0部署好的系统复制到hdisk2上,具体过程如下,所用命令用加重字体显示:
# lspv
hdisk0 0001d2613c5c29e9 rootvg active
hdisk2 0001f0755343a7f3 None
hdisk3 0001fe75533b6410 None
# alt_disk_install -C -O hdisk2
Calling mkszfile to create new /image.data file.
Checking disk sizes.
Creating cloned rootvg volume group and associated logical volumes.
Creating logical volume alt_hd5
Creating logical volume alt_hd6
Creating logical volume alt_hd8
Creating logical volume alt_hd4
Creating logical volume alt_hd2
Creating logical volume alt_hd9var
Creating logical volume alt_hd3
Creating logical volume alt_hd1
Creating logical volume alt_hd10opt
Creating logical volume alt_fwdump
Creating /alt_inst/ file system.
Creating /alt_inst/home file system.
Creating /alt_inst/opt file system.
Creating /alt_inst/tmp file system.
Creating /alt_inst/usr file system.
Creating /alt_inst/var file system.
Creating /alt_inst/var/adm/ras/platform file system.
Generating a list of files
for backup and restore into the alternate file system...
Backing-up the rootvg files and restoring them to the
alternate file system...
Modifying ODM on cloned disk.
Building boot image on cloned disk.
Resetting all device attributes.
NOTE: The first boot from altinst_rootvg will prompt to define the new system
console.
forced unmount of /alt_inst/var/adm/ras/platform
forced unmount of /alt_inst/var
forced unmount of /alt_inst/usr
forced unmount of /alt_inst/tmp
forced unmount of /alt_inst/opt
forced unmount of /alt_inst/home
forced unmount of /alt_inst
forced unmount of /alt_inst
Changing logical volume names in volume group descriptor area.
Fixing LV control blocks...
Fixing file system superblocks...
Bootlist is set to the boot disk: hdisk2
# lspv
hdisk0 0001d2613c5c29e9 rootvg active
hdisk2 0001f0755343a7f3 altinst_rootvg
hdisk3 0001fe75533b6410 None
# alt_disk_install -X
Bootlist is set to the boot disk: hdisk0
# lspv
hdisk0 0001d2613c5c29e9 rootvg active
hdisk2 0001f0755343a7f3 None
hdisk3 0001fe75533b6410 None
# rmdev -dl hdisk2
hdisk2 deleted
把hdisk2拔下来,放到新的机器/分区中,启动就可以了,这样一台变两台,两台变四台,很快
几个要点:
1,第一台服务器的操作系统要安装完整,补丁打好,需要集群的机器可以把oracle等软件装好,补丁也打好(这个是NIM做不到的,当然,前提是把这些东西放到rootvg当中),一定要确定好整体环境,不然以后一台一台补装软件可不好玩,这个是NIM的强项,呵呵。
2,拔下硬盘或者用分区把硬盘装到别的服务器/分区的后,第一次启动的时候,可能提示找不到可供启动的硬盘,这时候可以进入sms设定一下启动顺序,设定启动顺序的时候sms可以扫描硬盘,发现上面的操作系统。(darkbug)
1. 时间,时区 时间设置使用ntp来做
2. 安装CDE并设置Xmanager访问需要的配置
3. 扩充基本的文件系统,增加page space
4. 给操作系统打补丁,设置root的.profile
5. 设置系统的IP地址,注意系统是否需要做ether-channel
6. 调整AIX系统的参数如aio, ulimit等等
7. 根据应用设置/etc/hosts文件,不使用nameserver
8. core dump
[root@myhost/]# sysdumpdev -l
primary /dev/lg_dumplv
secondary /dev/sysdumpnull
copy directory /var/adm/ras
forced copy flag TRUE
always allow dump TRUE //通过控制面板(Control Panel)产生Dump的方法
dump compression ON
调节always allow dump为TRUE
#sysdumpdev -K
更改system dump device的primary device
#sysdumpdev -P -p /dev/lg_dumplv
9. ulimit参数相关,
将一段命令的结果赋值给一个变量
for example
dbbackup=`dsmadmc -id=admin -pa=admin -dataonly=yes select VOLUME_NAME from VOLHISTORY where BACKUP_SERIES=523`
echo $dbbackup
显示的结果是上面命令返回的值
注意这里"`dsmadmc -id=admin..." 是使用Tab上面的那个符号
反引号`
反引号括起来的字符串被shell解释为命令行,在执行时,shell首先执行该命令行,并以它的标准输出结果
取代整个反引号(包括两个反引号)部分
反引号还可以嵌套使用。但需注意,嵌套使用时内层的反引号必须用反斜线(\)将其转义。例如:
$ abc=`echo The number of users is \`who| wc-l\``
$ echo $abc
The number of users is 5
在反引号之间的命令行中也可以使用shell的特殊字符。Shell为得到``中命令的结果,它实际上要去执行``中指定的命令。
执行时,命令中的特殊字符,如$,”,?等又将具有特殊含义,并且``所包含的可以是任何一个合法的Shell命令
激活硬盘
chdev
chdev: 0514-502 Usage error -
Flag or parameter information is missing: -l.
Usage:
chdev -l Name [-a Attribute=Value]...[-p ParentName][-P|-T]
[-q][-w ConnectionLocation][-f File]
chdev -h
chdev -l hdisk1 -a pv=yes
阅读(1176) | 评论(0) | 转发(0) |