Chinaunix首页 | 论坛 | 博客
  • 博客访问: 17898684
  • 博文数量: 7460
  • 博客积分: 10434
  • 博客等级: 上将
  • 技术积分: 78178
  • 用 户 组: 普通用户
  • 注册时间: 2008-03-02 22:54
文章分类

全部博文(7460)

文章存档

2011年(1)

2009年(669)

2008年(6790)

分类: 系统运维

2008-05-20 20:18:44

The preparation for configuring any routing protocol requires a sound understanding of the network topology and a coherent addressing scheme. When you have these, the basic
configuration of Integrated IS-IS is as follows:
Step 1 Enable the router process Integrated IS-IS with the router isis command.
Step 2 Configure the NET address, thus assigning the area with the net networkaddress router subcommand.
Step 3 Enable Integrated IS-IS for IP on the relevant interfaces with the ip router isis interface subcommand.
Figure 7-9 illustrates a simple network to support the working configuration example. The figure shows the topology of the network and the addressing scheme that was used.
Figure 1 Basic Integrated IS-IS Configuration


Example 7-1 shows the basic configuration required to run Integrated IS-IS. The relevant
commands are highlighted for easy identification, and a brief explanation of the code is inserted
after an exclamation mark to make the code easier to read. Note the router process is started and
the NET address defined immediately beneath this router process because the IS-IS address is assigned to the router and as such is a part of the routing process. IS-IS is started on the interface
after the IS-IS router process is defined with a NET address.
Example 7-1 Basic Integrated IS-IS Configuration


Working Example for Router A
interface Ethernet0
ip address 140.100.96.1 255.255.255.0
! assign the IP address and mask
ip router isis
! start IS-IS on the interface
!
interface Serial0
no ip address
encapsulation frame-relay
no fair-queue
clockrate 56000
!
interface Serial0.1 point-to-point
ip address 140.100.64.1 255.255.255.0
! assign the IP address and mask
ip router isis
! start IS-IS on the interface
frame-relay interface-dlci 629
!
interface Serial0.2 point-to-point
ip address 140.100.32.1 255.255.255.0
! assign the IP address and mask
ip router isis
!start IS-IS on the interface
frame-relay interface-dlci 931
!
!
router isis
net 49.0001.0000.0000.000a.00
! Start the IS-IS routing process and define the ISO address for the entire router.
!
ip classless


Remember that by default Cisco routers are configured as Level 1-2 routers to avoid suboptimal
routing. Also the clns routing command is not required for IP-only IS-IS. In some versions of
the Cisco IOS software, clns routing is written into the configuration file automatically by
Cisco, when the routing process for IS-IS is configured.

Changing the Router from Level 1-2
Changing the routing level in Integrated IS-IS is done to overcome Integrated IS-IS consuming
resources on both the routers and the media. Using the topology in Figure 7-10, it is possible to
configure routers D, E, and F as Level 1 routers because they are internal to their areas. The command is just is-type level-1. This is a subrouter command and as such is placed under the
router isis command.
Figure 2 Changing the Level of Routing Both for the Entire Router and at the Interface Level


It is also possible to change the level of routing to Level 1 at the interface level by issuing the
isis circuit-type level-1 command under the interface. In Figure 7-10, this is done on the
Routers A, B, and C, the Ethernet interface pointing is configured to be running Level 1 routing,
while the serial interface runs only Level 2 routing.
Level 1-2 routers send LSPs with an ATT bit in their Level 1 LSPs, indicating that they are
attached to another area. This creates a default route in the Level 1 router, pointing to the nearest
Level 2 router. This allows the nearest Level 2 router to be the transit router for all data destined
for another area.
As illustrated in Figure 7-10, Example 7-2 shows Router A configured as Level 1 on the
Ethernet interface pointing to Router D; whereas, the other interfaces are configured as Level
2-only. The relevant commands are highlighted for easy identification.
Example 7-2 Changing Router A Routing Level on an Interface Basis

Working Example for Router A
interface Ethernet0
ip address 140.100.96.1 255.255.255.0
ip router isis
isis circuit-type level-1
!Configure Level 1 routing on the interface
!
interface Serial0
no ip address
encapsulation frame-relay
no fair-queue
clockrate 56000
!
interface Serial0.1 point-to-point
ip address 140.100.64.1 255.255.255.0
ip router isis
frame-relay interface-dlci 629
isis circuit-type level-2-only
! Configure Level 2 routing on the interface
!
interface Serial0.2 point-to-point
ip address 140.100.32.1 255.255.255.0
ip router isis
frame-relay interface-dlci 931
isis circuit-type level-2-only
!Configure Level 2 routing on the interface
!
!
router isis
net 49.0001.0000.0000.000a.00
!
ip classless


Example 7-3 shows the configuration command to change the level of routing on Router D to be Level 1. Note that this command appears under the router isis command, changing the behavior of the entire process rather than at the interface level. This example is illustrated in Figure 7-10. The relevant commands are highlighted for easy identification.

Example 7-3 Changing the Level of Routing for the Entire Router

Working Example for Router D
interface Ethernet0
ip address 140.100.96.2 255.255.255.0
no ip directed-broadcast
ip router isis
!
interface Serial0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
no fair-queue
!
interface Serial0.1
no ip directed-broadcast
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface BRI0
no ip address
no ip directed-broadcast
shutdown
!
router isis
net 49.0001.0000.0000.000d.00
is-type level-1
!Define the router as a Level 1 router
!
ip classless

[page]
Configuring Summarization
Configuring summarization is straightforward. The complexity is in the addressing scheme design. To configure summarization, enter the summary-address command followed by the summary address and mask under the router process. Figure 7-11 shows the topology used to support the working example shown in Example 7-4.
In Figure 7-11, the IP routes from Router B are summarized into areas 0001 and 0003. Router B is capable of summarizing routes because the router is both a Level 1 and Level 2 router, acting as an ABR in OSPF. Example 7-4 shows Router B summarizing routes 140.100.104.0 through to 140.100.107.0 with a mask summarized from /24 to /22. The relevant commands are highlighted for easy identification.

Figure 3 Summarizing IP Addresses Between IS-IS Areas


Example 7-4 Summarization of IP Routes from Router B


Working Example for Router B
interface Ethernet0
ip address 140.100.104.1 255.255.255.0
no ip directed-broadcast
ip router isis
isis circuit-type level-1
!
interface Serial0
no ip address
no ip directed-broadcast
encapsulation frame-relay
no ip mroute-cache
no fair-queue
clockrate 56000
!
interface Serial0.2 point-to-point
ip address 140.100.32.2 255.255.255.0
no ip directed-broadcast
ip router isis
isis circuit-type level-2-only
frame-relay interface-dlci 931
!
interface Serial0.3 point-to-point
ip address 140.100.16.2 255.255.255.0
no ip directed-broadcast
ip router isis
isis circuit-type level-2-only
frame-relay interface-dlci 631
!
!
router isis
summary-address 140.100.104.0 255.255.252.0
! Routes 140.100.104.0-140.100.107.0 summarized with the /22 bit mask.
net 49.0002.0000.0000.000b.00
!
ip classless

[page]

Configuring NBMA Frame Relay is a WAN technology that has evolved beyond the point-to-point capabilities. When configured in a full mesh, the cloud is multiaccess, although each circuit is discrete and therefore not a true broadcast medium. The configuration for IS-IS over the fully meshed Frame Relay cloud is illustrated in Figure 7-12, and there is a working example of the configuration in Example 7-5.
In Figure 7-12, the Frame Relay cloud has three fully meshed routers, which can operate as a LAN as far as IS-IS PDUs are concerned.
Figure 4 NBMA Frame Relay Cloud Running Broadcast Integrated IS-IS

[page]
In Example 5, the frame-relay map ip command maps the IP destination address to the
outgoing DLCI and defines the interface as a broadcast interface. Integrated IS-IS uses the links as if they were truly a broadcast link and elects a DIS.
The frame-relay map clns command maps to the CLNS process on the destination router.
Without the second command, no routes appear in the IP routing table because CLNS does not receive the frames to populate the IP routing table. Remember that these are IP routes carried in the IS-IS routing protocol. It is IS-IS that updates the IP routing table.
Example 7-5 NBMA Frame Relay Cloud, Running Broadcast Integrated IS-IS

Working Example for Router A <

阅读(308) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~