Chinaunix首页 | 论坛 | 博客
  • 博客访问: 829040
  • 博文数量: 860
  • 博客积分: 425
  • 博客等级: 下士
  • 技术积分: 1464
  • 用 户 组: 普通用户
  • 注册时间: 2011-08-20 19:57
个人简介

对技术执着

文章分类

全部博文(860)

文章存档

2019年(16)

2018年(12)

2015年(732)

2013年(85)

2012年(15)

我的朋友

分类: LINUX

2015-03-14 16:39:34

原文地址:wpa_supplicant更新问题 作者:futter521

上个星期成功解决了WPA-PSK加密的连接问题,这周尝试WPA2-PSK加密的连接,

整个上午都在测试wpa-supplicant.conf文件的配置,但依然不行,还是

4-Way Handshake failed - pre-shared key may be incorrect的问题


上午一点进展都没有,网上也找不到相关资料,重新编了无数次内核,把内核添加到接近3M的大小,不过也没什么作用。


后来想着,mx28内置的wpa_supplicant工具的版本是0.59,能不能支持上星期已经做成功的wpa-psk加密方式呢?ps:

那个是用0.73版本做成功的。


试验结果证实0.59版本的依然不给力,于是我知道,这个除了和内核有关,和wpa版本也有密不可分的关系。但网上最新的wpa工具也只是0.73而已,依然不支持wpa2-psk加密方式的连接吗。

于是我又想起wpa依赖的库openssl的版本,之前用的版本应该是0.98.于是果断从网上下了openssl最新的1.00e版本。

重新编译,有把wpa的依赖改为最新的openssl。果然这次完美支持wpa2了!
阅读(495) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~
评论热议
请登录后评论。

登录 注册