全部博文(1015)
分类:
2009-10-12 16:45:23
hostname R1
!
interface FastEthernet0/1
ip address 155.1.101.1 255.255.255.0
!-------connect with VM
duplex auto
speed auto
no cdp enable
!--------must be configured ,or you will cause some problem !
!
interface Serial1/0
ip address 155.1.0.1 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay map ip 155.1.0.2 102 broadcast
frame-relay map ip 155.1.0.3 103 broadcast
!-----frame-relay full meshed configuation
h323-gateway voip interface
h323-gateway voip id R2 ipaddr 155.1.0.2 1719
h323-gateway voip h323-id R1@abc.com
h323-gateway voip tech-prefix 1#
!------register to the Gatekeeper use H.323 Porotocol with ip 155.1.0.2 ,h323-id R1@abc.com
!------and the tech-prefix 1#
!------phone has only two way to register in a gatekeeper are E.164 address and tech-prefix
!
router ospf 1
log-adjacency-changes
network
!-------the basic route configuration
!
!
dial-peer voice 1 voip
destination-pattern 3...
session target ras
!------ Uses RAS messages (GK) to get call setup information.
tech-prefix 3#
!-------all call number prepends 3#
!
gateway
!------enable the gateway
timer receive-rtp 1200
!
!
telephony-service
max-ephones 2
max-dn 2
ip source-address 155.1.101.1 port 2000
auto assign 1 to 2
create cnf-files version-stamp Jan 01 2002 00:00:00
max-conferences 8 gain -6
transfer-system full-consult
!------basic CME configuration ,enable max 2 ephone,source-addrss 155.1.101.1,VM1 use this
!------ addrss to register IP soft phone(Cisco IP Communicator)
!
!
ephone-dn 1
number 1#1000
!------when VM2 calling VM1 ,it’s use a tech-prefix 1#,so the ephone number should adjust to
!------1#1000
!
!
ephone-dn 2
number 1001
!
!
ephone 1
mac-address
type CIPC
button 1:1
!------The IP soft phone auto register information
!
!
!
ephone 2
!
!---------------------------------------------------------------R3---------------------------------------------------
hostname R3
!
!
interface FastEthernet0/1
ip address 155.1.103.1 255.255.255.0
duplex auto
speed auto
no cdp enable
!
interface Serial1/0
ip address 155.1.0.3 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay map ip 155.1.0.1 301 broadcast
frame-relay map ip 155.1.0.2 302 broadcast
h323-gateway voip interface
h323-gateway voip id R2 ipaddr 155.1.0.2 1719
h323-gateway voip h323-id R3@abc.com
h323-gateway voip tech-prefix 3#
!
router ospf 1
log-adjacency-changes
network
!
!
dial-peer voice 1 voip
destination-pattern 1...
session target ras
tech-prefix 1#
!
gateway
timer receive-rtp 1200
!
!
telephony-service
max-ephones 2
max-dn 2
ip source-address 155.1.103.1 port 2000
auto assign 1 to 2
create cnf-files version-stamp Jan 01 2002 00:00:00
max-conferences 8 gain -6
transfer-system full-consult
!
!
ephone-dn 1
number 3#3000
!
!
ephone-dn 2
number 3001
!
ephone 1
mac-address
type 7960
button 1:1
!
ephone 2
!
!
hostname R2
!
ip domain name abc.com
!------configurate a domain name
!
interface Serial1/0
ip address 155.1.0.2 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
serial restart-delay 0
frame-relay map ip 155.1.0.1 201 broadcast
frame-relay map ip 155.1.0.3 203 broadcast
!
!
router ospf 1
log-adjacency-changes
network
!!
gatekeeper
zone local R2 abc.com 155.1.0.2
!-------configurate a local zone R2 ,and with a address 155.1.0.2 for register
!-------we can use [show gatekeeper zone status] to veryfy the ip addres
no shutdown
!
!----------------------------- -show gateway already registed in gatekeeper----------------
R2#sh gatekeeper endpoints
GATEKEEPER ENDPOINT REGISTRATION
================================
CallSignalAddr Port RASSignalAddr Port Zone Name Type Flags
--------------- ----- --------------- ----- --------- ---- -----
155.1.0.1 1720 155.1.0.1 51591 R2 VOIP-GW
H323-ID: R1@abc.com
Voice Capacity Max.= Avail.= Current.= 0
155.1.0.3 1720 155.1.0.3 51951 R2 VOIP-GW
H323-ID: R3@abc.com
Voice Capacity Max.= Avail.= Current.= 0
Total number of active registrations = 2
!----------------------------- -show registed gateway ‘s tech-prefix------------------------
R2#sh gatekeeper gw-type-prefix
GATEWAY TYPE PREFIX TABLE
=========================
Prefix: 1#*
Zone R2 master gateway list:
155.1.0.1:1720 R1
Prefix: 3#*
Zone R2 master gateway list:
155.1.0.3:1720 R3
!-----------------------------now we can see the gateway ‘s tech-prefix------------------------