Chinaunix首页 | 论坛 | 博客
  • 博客访问: 5574212
  • 博文数量: 1160
  • 博客积分: 12444
  • 博客等级: 上将
  • 技术积分: 12570
  • 用 户 组: 普通用户
  • 注册时间: 2008-03-13 21:34
文章分类

全部博文(1160)

文章存档

2016年(126)

2015年(350)

2014年(56)

2013年(91)

2012年(183)

2011年(193)

2010年(138)

2009年(23)

分类: LINUX

2015-08-15 11:36:13

http://www.cnblogs.com/tk091/p/3667600.html

1.更新软件源:

先备份软件源文件

 

 cp /etc/apt/sources.list /etc/apt/sources.list.bak

 

修改sources.list文件:

leafpad /etc/apt/sources.list

 

然后选择添加以下较快的源:

 

#官方源
deb kali main non-free contrib
deb-src kali main non-free contrib
deb http://security.kali.org/kali-security kali/updates main contrib non-free

#中科大kali源
deb kali main non-free contrib
deb-src kali main non-free contrib
deb -security kali/updates main contrib non-free

#新加坡kali源
deb kali main non-free contrib
deb-src kali main non-free contrib
deb http://security.kali.org/kali-security kali/updates main contrib non-free
deb http://mirror.nus.edu.sg/kali/kali-security kali/updates main contrib non-free
deb-src http://mirror.nus.edu.sg/kali/kali-security kali/updates main contrib non-free

#debian_wheezy国内源

deb wheezy main non-free contrib
deb-src wheezy main non-free contrib
deb wheezy-proposed-updates main non-free contrib
deb-src wheezy-proposed-updates main non-free contrib
deb -security wheezy/updates main non-free contrib
deb-src -security wheezy/updates main non-free contrib
# 163 源
deb wheezy main non-free contrib
deb-src wheezy main non-free contrib
deb wheezy-proposed-updates main non-free contrib
deb-src wheezy-proposed-updates main non-free contrib
deb-src -security wheezy/updates main non-free contrib
deb -security wheezy/updates main non-free contrib

 

保存之后运行:

 

apt-get update && apt-get dist-upgrade

 

2.kali-linux安装中文输入法(以下任意选择一安装):

#拼音五笔

apt-get install fcitx-table-wbpy ttf-wqy-microhei ttf-wqy-zenhei

#经典的ibus

 

 apt-get install ibus ibus-pinyin

 

#fcitx拼音,个人推荐用这个

apt-get install fcitx fcitx-googlepinyin fcitx-pinyin fcitx-module-cloudpinyin

输入法安装完成后需要注销当前用户重新登录之后才能使用

3.kali-linux安装flash player:

 

apt-get install flashplugin-nonfree
update-flashplugin-nonfree --install

 

或者参看:ubuntu下安装flash

4.kali_linux安装最新iceweasel,并汉化

在软件源中添加

 

deb http://mozilla.debian.net/ wheezy-backports iceweasel-release

然后在终端执行以下代码

apt-get install pkg-mozilla-archive-keyring                                                   #导入PGP KEY
gpg --check-sigs --fingerprint --keyring /etc/apt/trusted.gpg.d/pkg-mozilla-archive-keyring.gpg --keyring /usr/share/keyrings/debian-keyring.gpg pkg-mozilla-maintainers            #新建钥匙环
apt-get update && apt-get install -t wheezy-backports iceweasel && apt-get install iceweasel-l10n-zh-cn

5.安装一些工具:

apt-get install gnome-tweak-tool                   #安装gnome管理软件
apt-get install synaptic                   #安装新立德
apt-get install file-roller                   #安装解压缩软件
apt-get install clementine                   #clementine音乐播放器
apt-get install smplayer                   #安装smplayer视频播放器
apt-get install terminator                   #安装多窗口终端

 6.Kali-linux设置vpn代理:

 

复制代码
apt-get install network-manager-openvpn-gnome
apt-get install network-manager-pptp
apt-get install network-manager-pptp-gnome
apt-get install network-manager-strongswan
apt-get install network-manager-vpnc
apt-get install network-manager-vpnc-gnome /etc/init.d/network-manager restart
复制代码

 

在高级设置中勾选所有选项(这里是个人尝试方式)

7.运行 Metasploit Framework 

 

依照kali linux网络服务策略,Kali没有自动启动的网络服务,包括数据库服务在内。所以为了让metasploit以支持数据库的方式运行有些必要的步骤。

 

启动Kali的PostgreSQL服务:Metasploit 使用PostgreSQL作为数据库,所以必须先运行它。

 

service postgresql start

 

可以用 ss -ant  的输出来检验PostgreSQL是否在运行,然后确认5432端口处于listening状态。

 

State Recv-Q Send-Q Local Address:Port Peer Address:Port
LISTEN 0 128 :::22 :::*8
LISTEN 0 128 *:22 *:*3
LISTEN 0 128 127.0.0.1:5432 *:*4
LISTEN 0 128 ::1:5432 :::*
启动Kali的Metasploit服务:随着PostgreSQL的启动和运行,接着我们要运行Metasploit服务。第一次运行服务会创建一个msf3数据库用户和一个叫msf3的数据库。还会运行Metasploit RPC和它需要的WEB 服务端。

 

service metasploit start

 

在Kali运行msfconsole:现在PostgreSQL 和 Metasploit服务都运行了,可以运行 msfconsole,然后用 db_status 命令检验数据库的连通性。

 

msf > db_status
[*] postgresql connected to msf3
msf >
配置Metasploit随系统启动运行:如果你想PostgreSQL和Metasploit在开机时运行,你可以使用update-rc.d启用服务。
update-rc.d postgresql enable

 

update-rc.d metasploit enable

    

 

 具体文章请参考 : http://xiao106347.blog.163.com/blog/static/215992078201342410347137/

阅读(3151) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~