Chinaunix首页 | 论坛 | 博客
  • 博客访问: 2639279
  • 博文数量: 631
  • 博客积分: 10716
  • 博客等级: 上将
  • 技术积分: 8397
  • 用 户 组: 普通用户
  • 注册时间: 2008-04-01 22:35
文章分类

全部博文(631)

文章存档

2020年(2)

2019年(22)

2018年(4)

2017年(37)

2016年(22)

2015年(1)

2013年(12)

2012年(20)

2011年(19)

2010年(20)

2009年(282)

2008年(190)

分类: 系统运维

2011-04-15 15:49:47

VSS Configure

 

1.定义domain----ID范围1-255

On Switch 1:

podx-vss-sw1#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

podx-vss-sw1(config)#switch virtual domain x

Domain ID 1 config will take effect only

after the exec command 'switch convert mode virtual' is issued 

podx-vss-sw1(config-vs-domain)#switch 1

podx-vss-sw1(config-vs-domain)#

 

On Switch 2:

podx-vss-sw2#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

podx-vss-sw2(config)#switch virtual domain x

Domain ID 1 config will take effect only

after the exec command 'switch convert mode virtual' is issued

 

podx-vss-sw2(config-vs-domain)#switch 2

podx-vss-sw2(config-vs-domain)#

 

 

2.定义优先级----越大越优先

On Switch 1:

pod1-vss-sw1(config-vs-domain)#switch 1 priority 110 

pod1-vss-sw1(config-vs-domain)#switch 2 priority 100

 

On Switch 2:

pod1-vss-sw2(config-vs-domain)#switch 1 priority 110

pod1-vss-sw2(config-vs-domain)#switch 2 priority 100

 

 

3.配置Virtual Switch Link (VSL)----最多8个10GE口捆绑(必须用10GE口)

  控制面板通过VSL实现两个机箱的CPU到CPU的通讯,数据面板通过VSL扩展本机箱的交换矩阵到远端。

On Switch 1: 

pod1-vss-sw1(config)#interface port-channel 1

pod1-vss-sw1(config)#no shut

pod1-vss-sw1(config-if)#switch virtual link 1

pod1-vss-sw1(config-if)#exit

pod1-vss-sw1(config)#interface range tenGigabitEthernet 1/4 - 5

pod1-vss-sw1(config-if-range)#no shut

pod1-vss-sw1(config-if-range)#channel-group 1 mode on

pod1-vss-sw1(config-if-range)#^Z

 

On Switch 2:  

pod1-vss-sw2(config)#int port-channel 2

pod1-vss-sw2(config-if)#no shut

pod1-vss-sw2(config-if)#switch virtual link 2

pod1-vss-sw2(config-if)#exit

pod1-vss-sw2(config)#interface range tenGigabitEthernet 1/4 - 5

pod1-vss-sw2(config-if-range)#no shut

pod1-vss-sw2(config-if-range)#channel-group 2 mode on

pod1-vss-sw2(config-if-range)#^Z

 

 

4.执行转换-----转换完记得重启(重启不分先后可独立完成),重启后端口命名变成三级编码,switch2的console不在可用,所有控制都通过switch1来做

On Switch 1: 

pod1-vss-sw1#switch convert mode virtual 

 

This command will convert all interface names

to naming convention "interface-type switch-number/slot/port",

save the running config to startup-config and 

reload the switch.

Do you want to proceed? [yes/no]: yes

Converting interface names

Building configuration...

 

On Switch 2:  

pod1-vss-sw2#switch convert mode virtual 

 

This command will convert all interface names

to naming convention "interface-type switch-number/slot/port",

save the running config to startup-config and 

reload the switch.

Do you want to proceed? [yes/no]: yes

Converting interface names

Building configuration... 

 

 

 

 

5.在SWITCH1 上对switch2的VSL作最终配置(注意这里不能用range)

 

pod1-vss-sw1(config)#interface port-channel 2

pod1-vss-sw1(config-if)#no shut

pod1-vss-sw1(config-if)#switch virtual link 2

pod1-vss-sw1(config-if)#exit

pod1-vss-sw1(config)#interface tenGigabitEthernet 2/1/4

pod1-vss-sw1(config-if)#channel-group 2 mode on

pod1-vss-sw1(config-if)#exit

pod1-vss-sw1(config)#interface tenGigabitEthernet 2/1/5

pod1-vss-sw1(config-if)#channel-group 2 mode on

 

6.到此为止两台65已经一台了,可以改名并保存配置

podx-vss-sw1#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

podx-vss-sw1(config)#hostname podx-vss

podx-vss(config)#^Z

podx-vss#

00:13:40: %SYS-5-CONFIG_I: Configured from console by console

podx-vss#

podx-vss#wr

Building configuration...

 

00:16:23: %PFINIT-SP-5-CONFIG_SYNC: Sync'ing the startup configuration to the standby Router.

[OK]

podx-vss#

 

至此VSS配置全部完成!!


 

 


 

7.查看VSS 状态

1) pod1-vss#sh module switch 1

 Switch Number:     1   Role:   Virtual Switch Active

----------------------  -----------------------------

Mod Ports Card Type                              Model              Serial No.

--- ----- -------------------------------------- ------------------ -----------

  1    5  Supervisor Engine 720 10GE (Active)    WS-S720-10G        SAD104707A7

  2    4  CEF720 4 port 10-Gigabit Ethernet      WS-X6704-10GE      SAL1104F8T3

  3   48  CEF720 48 port 10/100/1000mb Ethernet  WS-X6748-GE-TX     SAD074102UP

 

2)pod1-vss#sh module switch 2

 Switch Number:     2   Role:  Virtual Switch Standby

----------------------  -----------------------------

Mod Ports Card Type                              Model              Serial No.

  1    5  Supervisor Engine 720 10GE (Hot)       WS-S720-10G        SAD1047078E

  2    4  CEF720 4 port 10-Gigabit Ethernet      WS-X6704-10GE      SAL1103EERS

  3   48  CEF720 48 port 10/100/1000mb Ethernet  WS-X6748-GE-TX     SAD074206UM

 

 

3)pod1-vss#sh run switch 1

Building configuration...

 

Current configuration : 4278 bytes

!

interface GigabitEthernet1/1/1

 no switchport

 no ip address

 shutdown

!

interface GigabitEthernet1/1/2

 no switchport

 no ip address

 shutdown

!

interface GigabitEthernet1/1/3

 no switchport

 ip address 128.107.65.12 255.255.255.128

!

<…snip…>

          

4)pod1-vss#sh run switch 2

Building configuration...

 

Current configuration : 3741 bytes

!

interface GigabitEthernet2/1/1

 no switchport

 no ip address

<…snip…>

 

 

5)pod1-vss#sh switch virtual 

Switch mode                  : Virtual Switch

Local switch number          : 1

Local switch operational role: Virtual Switch Active

Peer switch number           : 2

Peer switch operational role : Virtual Switch Standby

 

6)pod1-vss#sh switch virtual link

VSL Status : UP

VSL Uptime : 18:36:43 UTC Apr 6 2007

VSL SCP Ping : Pass

VSL ICC Ping : Pass

VSL Control Link : Te1/1/4  

 

7)pod1-vss#sh switch virtual role

 

Switch  Switch Status  Preempt    Priority  Role     Session ID

        Number         Oper(Conf) Oper(Conf)         Local  Remote

------------------------------------------------------------------

LOCAL    1     UP      FALSE(N)     110(110) ACTIVE    0      0   

REMOTE   2     UP      FALSE(N)     100(100) STANDBY   4217   6561

 

 


 

In dual-active recovery mode: No


 

 

8.功能性配置

  VSS配置完并工作正常后就可以进行功能性配置了,功能性配置和传统交换机是一模一样的,只是在做配置时可以将两台交换机可以看作一台(比如可以跨机箱做port-Channel)

 

9.重启active交换机

 1)podx-vss#redundancy reload shelf 1

 Reload this shelf [confirm]

 Preparing to reload this shelf

  active的交换机会触发一个NSF/SSO切换,standby的交换机会成为active,这个切换过程是比较短的。

重启期间vss状态----switch 2变成了active,可以通过show 查看

 

2)podx-vss#sh switch virtual 

Switch mode                  : Virtual Switch

Local switch number          : 2

Local switch operational role: Virtual Switch Active

 

3)重启完后再看VSS状态----switch2 是active switch 1是standby

podx-vss#sh switch virtual 

Switch mode                  : Virtual Switch

Local switch number          : 2

Local switch operational role: Virtual Switch Active

Peer switch number           : 1

Peer switch operational role : Virtual Switch Standby

podx-vss#sh switch virtual role  

Switch  Switch Status  Preempt    Priority  Role     Session ID

        Number         Oper(Conf) Oper(Conf)         Local  Remote

------------------------------------------------------------------

LOCAL    2     UP      FALSE(N)     100(100) ACTIVE    0      0   

REMOTE   1     UP      FALSE(N)     110(110) STANDBY   4252   7907

 

 

10. VSLP Link Management Protocol (LMP) information,主要用来管理VLS组中的成员工作情况。

pod1-vss#sh vslp lmp summary 

 

Instance #2:

 

 

  LMP summary

 

    Link info:        Configured: 2        Operational: 2

 

                               Peer Peer           Peer   Peer        Timer(s) running

Interface   Flag State         Flag MAC            Switch Interface   (Time remaining)

------------------------------------------------------------------------------------

Te2/1/4     vfs  operational  vfs  0013.5f1f.6740  1       Te2/1/4     T4(16ms) 

T5(59.96s)  

Te2/1/5     vfs  operational  vfs  0013.5f1f.6740  1       Te2/1/5     T4(16ms) 

T5(59.96s)  

 

 Flags: v - Valid    f - Flag set 

 T4 - Hello Tx Timer   T5 - Hello Rx Timer

 

pod1-vss#sh vslp lmp neighbors 

 

Instance #2:

 

 

  LMP neighbors

 

    Peer Group info:        # Groups: 1 

 

PG #    MAC             Switch  Ctrl Port

-----------------------------------------

*1      0013.5f1f.6740  1        1/4    

 

 

pod1-vss#sh vslp lmp counters 

 

Instance #2:

 

 

  LMP counters

             Tx                              Rx

Port    OK      Fail            Bidir   Uni     Fail    Bad

--------------------------------------------------------------------

 1/4    2883    0               2837    2       0       0      

 1/5    2883    0               2836    4       0       0      

 

                          Rx error details

Port    My info     My info     Bad MAC     Bad switch  Domain id   Peer info

        mismatch    absent      Address     id          mismatch    mismatch

----------------------------------------------------------------------------

 1/4    0           2           0           0           0           0          

 1/5    0           4           0           0           0           0

 

11. VSLP Ping

可以在Active 交换机中执行VSLP PING来检查VSL组中的每对接口工作是否正常

pod1-vss#ping vslp output interface tenGigabitEthernet 2/1/4

 

Type escape sequence to abort.

Sending 5, 100-byte VSLP ping to peer-sup via output port 2/1/4, timeout is 2 seconds

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms

 

pod1-vss#ping vslp output interface tenGigabitEthernet 2/1/5

 

Type escape sequence to abort.

Sending 5, 100-byte VSLP ping to peer-sup via output port 2/1/5, timeout is 2 seconds

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/16 ms

阅读(5011) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~