Chinaunix首页 | 论坛 | 博客
  • 博客访问: 17561
  • 博文数量: 5
  • 博客积分: 210
  • 博客等级: 二等列兵
  • 技术积分: 35
  • 用 户 组: 普通用户
  • 注册时间: 2009-06-15 17:27
文章分类

全部博文(5)

文章存档

2016年(1)

2009年(4)

我的朋友

分类: LINUX

2009-07-08 09:51:32

Opear下无法使用scim:
  sudo gedit /usr/bin/opera
  第二行空白处输入:
  export QT_IM_MODULE=XIM
  英文环境下使用scim:
  sudo gedit /etc/X11/Xsession.d/95xinput
  输入:
  export XMODIFIERS=@im=SCIM
  export GTK_IM_MODULE=scim
  export QT_IM_MODULE=scim(如果没有QT程序可以不加)
  scim -d
  然后保存,注销,重新进入就可以了。
  EVA与Scim冲突的解决方法:
  sudo apt-get install scim-bridge
  编辑im-switch生成的scim配置文件
  sudo gedit /etc/X11/xinit/xinput.d/scim
  将默认的 GTK_IM_MODULE=scim 修改为 GTK_IM_MODULE="scim-bridge"
  将默认的 QT_IM_MODULE=scim 修改为 QT_IM_MODULE="xim"
  ------------修改后的内容如下:---------------
  # im-switch configuration file for scim
  # should be installed as /etc/X11/xinit/xinput.d/scim
  # this configuration uses GTK IM module and Qt IM module provided by SCIM
  # exported enviroment variables
  XMODIFIERS="@im=SCIM"
  GTK_IM_MODULE="scim-bridge"
  QT_IM_MODULE="xim"
  # command and arguments to invoke scim
  XIM_PROGRAM="/usr/bin/scim"
  XIM_ARGS="--daemon"
  # package dependency (note that the format used here is not environment
  # variable, but some format for libapt-pkg-perl and is parsed by grep,
  # so can't be quoted, and no spaces allowed)
  DEPENDS=scim-gtk2-immodule,scim-qtimm
阅读(373) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~