Chinaunix首页 | 论坛 | 认证专区 | 博客

iihero@ChinaUnixehero.blog.chinaunix.net

iihero's LAB [SAP/Sybase DB, PG, Oracle/MySQL, SQLite etc]

  • 博客访问: 751830
  • 博文数量: 232
  • 博客积分: 50
  • 博客等级: 民兵
  • 技术积分: 3948
  • 用 户 组: 普通用户
  • 注册时间: 2007-09-11 13:11
个人简介

iihero@ChinaUnix, ehero.[iihero] 数据库技术的痴迷爱好者. 您可以通过iihero AT qq.com联系到我 以下是我的三本图书: Sybase ASE in Action, Oracle Spatial及OCI高级编程, Java2网络协议内幕

文章分类

全部博文(232)

文章存档

2014年(4)

2013年(228)

微信关注

IT168企业级官微



微信号:IT168qiye



系统架构师大会



微信号:SACC2013

分类: Sybase

看到有很多提起说ASE15.7不能在xp下安装,感到很奇怪。在我印象里,15.7是支持32位xp的,虽然主要面向64位系统。
由于它依赖于VCruntime 2005的运行时库,很多人没有看安装要求,直接安装,结果导致一些意想不到的错误。

1. 简单看需求

完整的需求在:http://infocenter.sybase.com/help/topic/com.sybase.infocenter.dc35888.1570/doc/html/jon1256241632272.html
它明确说了:
Use either of the following patches for both X86 and X64:
  • Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package and KB973544
  • Microsoft Visual Studio 2005 Service Pack 1 and KB971090
安装上述两个中的一个就行了。
从哪儿下载呢?直接搜,还真不好搜。建议下载这个:
http://www.microsoft.com/zh-cn/download/confirmation.aspx?id=5638#
如果还下载不到,我共享了一个:
http://pan.baidu.com/s/1jCpg6

2. 下载软件

SAP Sybase ASE 15.7是可以下载到Developer版本的,实际上是一个完整的版本,可以选择带license, 开发版或者评估版。
带license, 需要花钱买,后两者一个是永久使用,一个是30天试用。开发人员一般使用开发版,足够了。
从这里可以下载到完整的安装包:
http://download.sybase.com/eval/157/ase157_winx86.zip

如果访问不到这个网址的,请访问这个:
http://pan.baidu.com/s/13VdAB

3. 一路安装

先把vcredist_x86_vs2005.exe给安装了,
之后解开ase157_winx86.zip,把典型安装里头的选项,都给选上。就一切OK了。
有人说,这个安装不会有Sybase Central,这是错误的。它确实带有Sybase Central客户端。

不过,以后有没有就说不准了。SCC将来会完全替代Sybase Central.
阅读(4099) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~
评论热议
请登录后评论。

登录 注册