Chinaunix首页 | 论坛 | 博客
  • 博客访问: 498488
  • 博文数量: 79
  • 博客积分: 10
  • 博客等级: 民兵
  • 技术积分: 1326
  • 用 户 组: 普通用户
  • 注册时间: 2012-06-12 08:51
个人简介

XMU->九天揽月->五湖抓鳖->DSP->driver->kernel/OpenWRT->ISP/RTOS

文章分类

全部博文(79)

文章存档

2020年(2)

2018年(3)

2016年(7)

2015年(42)

2014年(25)

分类: LINUX

2015-05-06 17:35:43

OpenWRT平台的package管理有自己的Makefile,不同于gcc的Makefile,
这个Makefile是作为OpenWRT强大的package管理的关键组件。
要想往OpenWRT添加自己的package,就得按照它的方式去写个pack依赖。
有了这个,target的pack运行时依赖的所有标准、第三方、自己的组件都可以在编译时一并解决依赖问题了,
而不是等到下载到板子上才发现缺少库。

举个栗子,一个常见的openwrt package Makefile如下:

  1. define Package/mypack/default
  2. SECTION:=net
  3. CATEGORY:=Network
  4. DEPENDS:=+libpthread
  5. TITLE:= my own package for network utility
  6. endef
最常见的形式就是 
DEPENDS:=+libpread
表示一旦你选中mypack,那么libpthread也就会同时被后台默认选中,推荐。

DEPENDS:=libpread
意味着因为依赖关系,只有在先选中libpthread后,才可以选择mypack。

DEPENDS:=+arpd:libpthread
这是一个双重依赖,只有arpd选中后,才可以选择libpthread,这样看有些拗口。
但是在前面取个反就很实用了,比如这个定义
DEPENDS:=+!BUSYBOX_CONFIG_arp:net-tools-arp
表示若busybox的arp没有包含(busybox的工具都是阉割版),那么就选中arp(标准版)。

DEPENDS:=@libpread
表示除非你先选中libpread,否则休想在menuconfig看到mypack。不推荐

DEPENDS:=+@libpthread
多个+呢,和+libpthread类似,会自动选择libpthread。
但是,有一点这种方式在安装mypack到target文件系统时,不会去检查依赖性的,若libpthread没有被安装它是检测不出来的,
只能在target上运行时才能发现 undefined symbol


阅读(4996) | 评论(0) | 转发(1) |
给主人留下些什么吧!~~