Time Limit: 1sec Memory Limit:32MB
Description
请用类描述顶点信息,输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。
Input
输入数据第一行一个整数 n,代表测试数据组数,接下来 n 行,每行由 4 个实数组成,分别表示 x1,y1,x2,y2,数据之间用空格隔开。
Output
Sample Input
2
0 0 0 1
0 1 1 0
Sample Output
1.00
1.41
- // source code of submission 684632, Zhongshan University Online Judge System
- #include<stdio.h>
- #include<math.h>
- struct nood
- {
- double a;
- double b;
- double c;
- double d;
- };
- int main()
- {
- int t,x;
- int i;
- double j;
- scanf("%d",&t);
- struct nood m[t];
- x=t;
- i=0;
- while(t)
- {
- scanf("%lf%lf%lf%lf",&m[i].a,&m[i].b,&m[i].c,&m[i].d);
- i++;
- t--;
- }
- i=0;
- while(x)
- {
- j=sqrt(pow(m[i].d-m[i].b,2)+pow(m[i].c-m[i].a,2));
- printf("%.2lf\n",j);
- x--;
- i++;
- }
- return 0;
- }