Chinaunix首页 | 论坛 | 博客
  • 博客访问: 340787
  • 博文数量: 122
  • 博客积分: 5000
  • 博客等级: 大校
  • 技术积分: 1191
  • 用 户 组: 普通用户
  • 注册时间: 2009-10-24 11:12
文章分类

全部博文(122)

文章存档

2010年(122)

我的朋友

分类: C/C++

2010-03-26 00:44:12

一、问题描述

Description

A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.

Query-1: "Every five minutes, retrieve the maximum temperature over the past five minutes."
Query-2: "Return the average temperature measured on each floor over the past 10 minutes."


We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency.

For the Argus, we use the following instruction to register a query:

Register Q_num Period


Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds.

Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num.

Input

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of "#".

The second part is your task. This part contains only one line, which is one positive integer K (<= 10000).

Output

You should output the Q_num of the first K queries to return the results, one number per line.

Sample Input

Register 2004 200

Register 2005 300

#

5

Sample Output

2004

2005

2004

2004

2005

二、解题思路

       使用最小堆。堆的节点结构如下:

struct Reg

{

       int Now;//出堆的时间

       int Q;//Q_num

       int P;//Period

       };

       首先按关键字Now(如果Now相等,则Q作为关键字)建立一个最小堆,然后将堆顶元素的Q值输出,同时将该元素Now+=P,然后以堆顶元素为起点重新调整堆为最小堆。然后将堆顶元素输出,修改Now值,调整堆…...重复这个过程直到输出KQ值。

三、代码

 

#include<iostream>
#include<string>
#include<algorithm>
#include<vector>
using namespace std;
struct Reg
{
    int Now;//出堆的时间

    int Q;    //Q_num

    int P;    //Period

};
Reg R[3001];//保存注册信息

int K;        //输出个数

//调整堆

void HeapAdjust(Reg H[] ,int s,int m)
{
    Reg rc=H[s];
    int j;
    for(j=s*2;j<=m;j*=2)
    {
        if(j<m )
        {
            if(H[j].Now > H[j+1].Now)
                j++;
            else
            {
                if((H[j].Now == H[j+1].Now) && (H[j].Q > H[j+1].Q) )
                    j++;
            }
        }
        if(rc.Now < H[j].Now || (rc.Now==H[j].Now && rc.Q <H[j].Q))
            break;
        H[s]=H[j];
        s=j;
    }
    H[s]=rc;
}
//建立一个最小堆

void MakeHeap(Reg H[],int length)
{
    for(int i=length/2;i>0;--i)
    {
        HeapAdjust(H,i,length);
    }
}

int main()
{
    string str;
    int i=1;
    cin>>str;
    while(str.compare("#")!=0)
    {
        cin>>R[i].Q>>R[i].P;
        R[i].Now=R[i].P;
        i++;
        cin>>str;
    }
    int len=i-1;
    cin>>K;
    MakeHeap(R,len);
    for(i=1;i<=K;++i)
    {
        cout<<R[1].Q<<endl;
        R[1].Now+=R[1].P;
        HeapAdjust(R,1,len);
    }
    return 0;
}


阅读(1451) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~